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WORKING WITH BASIC FUNCTIONS

A function is a predefined formula that performs calculations
using specific values in a particular order.

Excel includes many common functions that can be useful for
quickly finding the sum, average, count, maximum value, and
minimum value for a range of cells. In order to use functions
correctly, you'll need to understand the different parts of a
function and how to create arguments to calculate values and cell

references.

Formula =A1+A2+A3+A4+A5+A6+A7+A8

Function =SUM(AT1:A8)

The parts of a function

The order in which you insert a function is important. Each
function has a specific order—called syntax—which must be
followed in order for the function to work correctly. The basic
syntax to create a formula with a function is to insert an equals
sign (=), function name (SUM, for example, is the function name
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for addition), and argument. Arguments contain the information
you want the formula to calculate, such as a range of cell
references.

=SUM(B3:B12)

name

Working with arguments

Arguments must be enclosed in parentheses. Individual values or
cell references inside the parentheses are separated by
either colons or commas.

. Colons create a reference to a range of cells.
For example, =ZAVERAGE(E19:E23) would calculate
the average of the cell range E19 through E23.

. Commas separate individual values, cell references, and cell
ranges in parentheses. If there is more than one argument, you must
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separate each argument by a comma.

For example, =COUNT(C6:C14,C19:C23,C28) will count all the
cells in the three arguments that are included in parentheses.

To create a basic function in Excel:

1. Select the cell where the answer will appear (F15, for example).

2. Type the equals sign (=), then enter the function name (SUM, for
example).

3. Enter the cells for the argument inside the parentheses.
Unit Price  Subtotal Date Ordered Date Received

55.86 $58.60 12-Sep 17-Sep
540.26 $80.52 12-Sep 17-Sep
54.20 542,00 6-Sep 12-Sep
$6.19|  $74.28 6-Sep 12-Sep
53.20 $48.00 6-Sep 12-Sep
53.40 $17.00 6-Sep 12-Sep
54.10 $32.80 6-Sep 12-Sep
$12.20  $61.00 8-Aug 11-Aug
$7.33 $36.65 8-Aug 11-Aug

|=sum(Fe:F1a)

4. Press Enter, and the result will appear. ~ $450-85
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Using AutoSum to select common functions

The AutoSum command allows you to automatically return the

results for a range of cells for common functions like SUM and
AVERAGE.

1. Select the cell where the answer will appear (E24, for example).
2. Click the Home tab.

3. In the Editing group, click the AutoSum drop-down arrow and
select the function you want (Average, for example)

Format

- Average
Count Mumbers
Max
K Min

More Functions...

4. A formula will appear in E24, the selected cell. If logically placed,
AutoSum will select your cells for you. Otherwise, you will need to
click the cells to choose the argument you want.
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Unit Price  Subtotal Date Ordered Date Received

r ”””” $36.09 18-Sep 26-Sep
! 531.90 18-Sep 26-Sep
E $58.70 8-Aug 14-Aug
! 588.30 B-Aug 14-Aug
!

527.08 22-Jul 25-Jul

AVERAGE(numberl, [numberZ], ...)

5. Press Enter, and the result will appear. S11.24

The Function Library

There are hundreds of functions in Excel, but only some will be
useful for the type of data you're working with. There is no need
to learn every single function, but you may want to explore some
of the different types to get ideas about which ones might be
helpful to you as you create new spreadsheets.

A great place to explore functions is in the Function Library on
the Formulas tab. Here, you can search and select Excel functions
based on categories such as Financial, Logical, Text, and Date &
Time.
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To insert a function from the Function Library:

1. Select the cell where the answer will appear (16, for example).
2. Click the Formulas tab.

3. From the Function Library group, select the function
category you want. In this example, we'll choose Date & Time.

4. Select the desired function from the Date & Time drop-down
menu. We'll choose the NETWORKDAYS function to count the
days between the order date and receive date in our worksheet.
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Insert

Page Layout

Formulas

Data Review

View

A3 De
1 0 eD S
f I @ E@E
Insert AutoSum Recently Financial Logical Text |Date & | Lookup & Math More Mame
Function = Used = = = Time = |Reference = & Trig = Functions = | Manager BS Cr
Function Librany DAY Y Defing
I 16 - fo| SNETWO  paysseo
A 8 EDATE E F
2 | Office Supply Order L Jul-Sep 2010
PPlY o8 P ECQMONTH
3
4 |OfficeMax HOUR
5 Office Supply Item Number MINUTE Unit Price  Subtota
6 |File Folders EGC338290 MONTH $5.86 $58.61
7 Copy Paper LBGA3576 o 540.26 580.5.
8 Paperclips CAD789237 $4.20 $42.01
9 Binder Clips (Multi) CAD256903 NETESORKDASINT ——
MNETWORKDAYS(start_date,end_date, holidays)
10 Pens (Blue) KLH78902 NO
Returns the number of whole workdays
11 Pens (Red) KLH78904 SEC| petween two dates.
12 Highligher Pens (Yellow) STA73298 ™
13 Sticky Notes JUG198430 @ Press F1 for more help.
gy . ———————— TIMEToTTTe ™ =

5. The Function Arguments dialog box will appear. Insert the cursor
in the first field, then enter or select the cell(s) you want (G6, for

1itity Type Unit Price al te Received Delivery Time
10 boxes $5.86 558.60 12-Sep: 1}'—Sep|'.KDAYS(GE-} |
............ | !
2 cartons $40.26 580.52 —Sep 17-Sep
5 = —— - — — — &Ig1
Function Arguments - - P o
METWORKDAYS
Start_date |Gs = 40433
End_date = any
Holidays = any

Returns the number of whole workdays between two dates.

Formula result =

Start_date is a serial date number that represents the start date.

i
t Help on this function

[ oc |[ canel |

6. Insert the cursor in the next field, then enter or select the cell(s)

you want (H6, for example).
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tity Type Unit Price =
10 boxes 55.86 - _
2 cartons $40.26 12-Sep
- ] — S
Function Arguments - - P— ra— &Iﬂ
METWORKDAYS
Start_date G = 40433
End_date |Hg| = 40438
Holidays = any

Returns the number of whaole workdays between two dates.
End_date is a serial date number represents the end date.
Formula resdlt = 5 *— l View formula result '
l
t Help on this function I O I ’ Cancel ]

— —— — = =
wx T TET >

7. Click OK, and the result will appear. Our results show that it took
five days to receive the order.

Date Ordered Date Received
12-Sep 17-5ep 5

Excel Formulas You Should Definitely Know
1. SUM Formula: =SUM(5, 5) or =SUM(AT1, B1) or =SUM(A1:B5)

The SUM formula does exactly what you would expect. It allows

you to add 2 or more numbers together. You can use cell

references as well in this formula.
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2. COUNT Formula: =COUNT(A1:A10) The count formula counts
the number of cells in a range that have numbers in them. It only

counts the cells where there are numbers.

3. COUNTA Formula: =COUNTA(A1:A10) Counts the number of
non-empty cells in a range. It will count cells that have numbers
and/or any other characters in them. The COUNTA Formula works
with all data types. It counts the number of non-empty cells no

matter the data type.

4. LEN Formula: =LEN(A1) The LEN formula counts the number of

characters in a cell. This includes spaces!

SORTING DATA

With more than 17 billion cells in a single worksheet, Excel 2010
gives you the ability to work with an enormous amount of data.
Arranging your data alphabetically, from smallest to largest, or
using other criteria can help you find the information you're
looking for more quickly.
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To sort in alphabetical order:

1. Select a cell in the column you want to sort by. In this example,
we'll sort by Last Name.

| c D E
1 Last Name Payment T-Shirt Color
2 [Olivera vy J1-Oct White
3 Richards 4-0ct Dark Red
4 Hanlon 3-0Oct Heather Grey
5 Means 5-Oct Dark Red

2. Select the Data tab, then locate the Sort and Filter group.

3. Click the ascending commandz+to Sort A to Z or the descending
commandito Sort Z to A.

Insert Page Layout Formulas Data Revie'

Connecti K Clear E
ﬂ onnections %l T xhk ar -

[ Properties ";q Reapply
o Zl Sort Filter Te

@ Edit Links = W2 Advanced Co
nections Sort & Filter

- Sort AtoZ 1

C Sort the selection so that the
lowest values are at the top of the

M colummn. L
Olivera i
Richards 9 Press F1 for more help.
Hanlon |5—Gct |—ea:-'5’ Grey

4. The data in the spreadsheet will be organized alphabetically.
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C D E
1 Last Name Payment T-Shirt Color
2 |Ackerman 1-Oct Heather Grey
3 Albee 13-Oct Heather Grey
4 Bell 11-Oct Dark Red
5 Benson 11-Oct White
6 Chen 5-Oct Dark Red
7 Del Toro 13-0Oct White
8 Ellison Pending Dark Red
9 |Flores 6-Oct White
10 |Hanlon 5-Oct Heather Grey
11 Kelly 11-Oct Dark Red
12 |Kelly 11-Oct Heather Grey
13 Lazar 14-Oct White
14 MacDonald Pending Dark Red
15 Means 5-0Oct Dark Red
16 Maser 14-Oct Dark Red
17 |Michols 6-0Oct Dark Red

Sorting options can also be found on the Home tab, condensed
into the Sort & Filter command.

CHARTS

Excel workbooks can contain a lot of data, and this data can often
be difficult to interpret. For example, where are the highest and
lowest values? Are the numbers increasing or decreasing?

The answers to questions like these can become much clearer
when data is represented as a chart. Excel has various types of
charts, so you can choose one that most effectively represents
your data.
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To create a chart:

1. Select the cells you want to chart, including the column
titles and row labels. These cells will be the source data for the

chart.
A B C D E F

]_ - = - UE R UL - Bk - LS - iy -
2 Young Adult  $35,358.00 $42,685.00 $20,893.00 $16,065.00 $21,388.00
3 |Classics 518,580.[13 $49,225.[l] 516,326.[[! 510,01?.[11 526,134.[[!
4 |Mystery  $78,970.00
5 |Romance 594,236.00 $131,390.00 579,022.00 571,009.00 581,474.00
6 $16,730.00  $19,730.00 $12,109.00 $11,355.00
7

2. Click the Insert tab.

3. In the Charts group, select the desired chart category (Column,
for example).

] Insert [ Page Layout Formulas Data Review View I Design l
ElEl IﬁJShapes' ' . .\J
hal g 2 .t
T2 smartart
Picture Clip .. Column  Line Pie Bar Area  Scatter Other
Art et Screenshot - - - - - - - Charts =
Tllustrations | b Charts |
ML e | Genre | column
B C Insert a column chart, G
n 2006 = 2007 My Column charts are used to compare

4. Select the desired chart type from the drop-down menu (Clustered
Column, for example).
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Insert Page Layout Formulas Review Design
BlE) @ srapes- ;boc e =, ‘. .
‘SmartArt
Picture Clip .. X Culumn Llne Ple Bar Area Scatter Other
Art st Screenshot + - Charts =
Tllustrations || 2-D Column [F}

- (= 5 | Genre
B C G

B 2006Bd 2007 E

._ 3-0) Clustered Column

Compare values across categories
by using vertical rectangles.

Use it when the order of categories
£$94,236.00 5131,390.00 ©| is not important or for displaying

item counts such as a histogram,

5. The chart will appear in the worksheet.

A B C D E F G

e e - 006 &4 00 - 008 R4 0095 R4 010 K
Classics $18,580.00 $49,225.00 $16,326.00 $10,017.00 $26,134.00)
Mystery $78,970.00 $82,262.00 $48,640.00 $49,985.00 $73,428.00)
Romance $94,236.00 $131,390.00 $79,022.00 $71,009.00 $81,474.00)
Sci-Fi & Fantasy |$16,730.00 $19,730.00 $12,109.00 $11,355.00 $17,686.00)
Young Adult  |$35358.00 $42,685.00 $20,893.00 $16,065.00 $21,388.00

1
2]
|3
|4
=N

6

7
| o 5140,000.00
|8

3 $120,000.00

10

1 $100,000.00 I u Classics
12 $80,000.00 1 Myste ry
13 L
[ i 1| ® Romance
- ‘| se0,000.00
- W SciFi & Fantasy
15 $40,00000 +— -

e Young Adult
- $20,00000 | =
|18 $0.00

19 2006 2007 2008 2009 2010

20

To change chart type:

1. From the Design tab, click the Change Chart Type command. A
dialog box appears.



AL-Mustagbal university college
Class: 1%

Subject: Computer Applications
Lecturer: Rami Qays Malik

Lecture :Part-2-4th lec

E-mail : rami.gays@mustagbal-college.edu.iq

L S =

Save As Switch Select
Chart Type Template = Row/Column Data

Type Data

Change Chart Type S
Change to a different type of chart.
T

2. Select the desired chart type, then click OK.

("Change Chart Type [ 9 o
C@ Templates T T 3 | 1 | Y -
S]] bA|[BA] b
kx tine Line
& Pie ] ] - L __. ] =
e |l il bl A R
M area Pie Line with Markers
A B ®| @ N @) €z
6 Ssurface sar
@ Doughnut — — —=1 — — —
= |EE| =SS S E

| | & | & | o] (B | > |-
[ manage T .. | | setasDefaut chart | [ ok ][ cone ]

WHAT-IF ANALYSIS

Excel includes many powerful tools to perform complex
mathematical calculations, including what-if analysis. This feature
can help you experiment and answer questions with your data,
even when the data is incomplete
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Using Goal Seek

When you create a formula or function in Excel, you put various
parts together to calculate a result. Goal Seek works in the
opposite way: It lets you start with the desired result, and it
calculates the input value that will give you that result.

To use Goal Seek

Let's say you're enrolled in a class. You currently have a grade of
65, and you need at least a 70 to pass the class. Luckily, you have
one final assignment that might be able to raise your average.
You can use Goal Seek to find out what grade you need on the
final assignment to pass the class.

In the image below, you can see that the grades on the first four
assignments are 58, 70, 72, and 60. Even though we don't know
what the fifth grade will be, we can go ahead and write a formula
or function that calculates the final grade. In this case, each
assignment is weighted equally, so all we have to do is average all
five grades by typing =AVERAGE(B2:B6). Once we use Goal Seek,
cell B6 will show us the minimum grade we'll need to make on the
final assignment.
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SUM v(‘ KV fr| =AVERAGE(B2:B6)
A B c | b |

1 Ftar: ade

ZTestl 58

3 Paperl 70

.4 [Test2 72

3 Paper2 60

6 Test3

_ 7 |Final =AVERAGE{BZ:BErl

B

1. Select the cell containing the value you want to change. When you
use Goal Seek, you'll need to select a cell that already contains
a formula or function. In our example, we'll select cell B7 because
it contains the formula =AVERAGE(B2:B6).

Fi—

B7 - fc | =AVERAGE(B2:86)
A B c | b |

il g 1de

2 Testl 58

3 Paperl 70

4 [Test2 72

5 |Paper2 60

6 Test3

_ 7 |Final Grade | 654 !

8

2. From the Data tab, click the What-If Analysis command, then
select Goal Seek from the drop-down menu.

Data Review View
() connections \r & Clear = E = B = B ®rE @rm oEr
2 312 = H (= . wE  EE B
[T Properties LA {; Reapply J——iﬂ ¥ — d-" L L @
%1 Sort Filter 7, Textto Remove Data Consolidate| What-If || Group Ungroup Subtotal
= Edit Links 7 Advanced | Columns Duplicates Validation ~ |Analysis * - v
onnections Sort & Filter Data Tools | Scenario Manager... ptline
32:86) Goal Seek... %
|_E F G H | K | L | Datalable.

3. A dialog box will appear with three fields:
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o Set cell: This is the cell that will contain the desired result.
In our example, cell B7 is already selected.

o Tovalue: This is the desired result. In our example, we'll
enter 70 because we need to earn at least that to pass the
class.

o By changing cell: This is the cell where Goal Seek will
place its answer. In our example, we'll select
cell B6 because we want to determine the grade we need to
earn on the final assignment.

4. When you're done, click OK.

A B C D E

il Assignment Grade
2 Testl 58
3 Paperl 70
4 Test2 72
5 Paper2 60

6 |Tests [ |
7 Final Grade 65
8
9 Goal Seek m‘
i Set cell: . 1
11 -
12 To value: 1
13 By changing cell: 1
& [ o ,\;_] [ canca ||F
15 lay

16

5. The dialog box will tell you if Goal Seek was able to find a
solution. Click OK.

r A
Goal Seek Status m

Goal Seeking with Cell B7 | Step |
found a solution.

Target value: 70 | felies |
Current value: 70




