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2. Variable Type: The function of this column is to specify the data type that will 

be entered for this variable in the data view sheet. When selecting it, a button 

appears, and upon clicking it, a dialog box containing several types of variables 

appears. We choose one of them, and these types are:  

 

1-Numeric: A numerical variable, which is the default type for variables in the data 

view sheet. 

2- Comma: A numerical variable with the addition of a comma (,) as a separator 

between every three decimal places. For example, the number 622776.022 is 

written as 622,776.022 using this type. 

3- Dot: A numerical variable using (.) to separate every three decimal places. A 

comma (,) is used to separate the integer part from the decimal part. For example, 

the previous number is written as 622.776,022 based on this choice. 

3- Scientific notation: A symbol written in exponential notation (E-notation). For 

example, the number 5^10 is written as 1.0E+05. 

4- Date: A variable representing the date or time, such as time in hours. 

5- Dollar: Used as a symbol for the U.S. dollar. 

6- Custom currency: Used to define the currency for the function, adjustable from 

Edit > Options > Currency. 
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7- String: A symbolic variable (e.g., a name) used when the variable's data 

consists of symbols or names, not numbers. 

3. Variable Width Display: 

 The variable width represents the number of characters allocated for the numeric 

part plus the decimal point character, and the remaining characters are assigned 

to the integer part in the case of numeric variables. As for non-numeric variables, 

the variable width represents the number of characters allocated to the non-

numeric variable. Note that the variable width can also be specified from the 

variable type dialog box. 

4. Decimal Places: 

Decimals represent the number of decimal places assigned for the decimal 

fraction in numeric variables (dot, comma, numeric). The decimal places can be 

increased or decreased using arrows up or down. It is worth noting that decimal 

places can also be specified from the variable type dialog box. 

5. Variable Label: 

A variable label can cover an address of up to 256 characters used to describe the 

variable. This label is used instead of the variable name in outputs (tables) in the 

SPSS program. 

6. Value Label: 

Sometimes there is a need to assign a label to a value since the variable uses 

numerical values to express non-numeric values. For example, the number 1 may 

represent males, and the number 2 may represent females. Alternatively, letters 

can be used instead of words, as in the image: 

 

The dialogue box in the above image appears, where we enter the number or letter 

in the "value" field and the word or phrase in the "label" field. After activating it, 

we press the "Add" key, and the corresponding number and symbol are added. 
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7. Definition of Missing Values: Sometimes, we want to define some missing 

values, meaning that these values already exist, but we do not want to include 

them in the statistical analysis, either because they are values, we do not want to 

include in the statistical analysis or because they are fundamentally nonexistent. 

The dialogue box appears in the image below: 

 

8. Column Width: The width of a specific column can be determined by selecting 

the cell within the column in the "Variable View" sheet. The column width can be 

increased or decreased using the arrows up or down, or by directly entering the 

column width. 

9. Text Alignment: To adjust the text alignment within variable cells, choose the 

column labeled "align" in the "Variable View" sheet and select one of the following 

commands: 

   - Left: Aligns the text to the left of the cell. 

   - Right: Aligns the text to the right of the cell. 

   - Center: Aligns the text in the center of the cell. 

10. Measurement: To define the measurement scale for a specific variable, click 

on the cell of the variable located within the "measure" column in the "Variable 

View" sheet. Three options will appear, as follows: 
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- Scale: Used for numerical data (quantitative measurements) such as length, 

weight, etc. 

- Ordinal: Used to measure ordinal variables when the variable has a specific 

number of categories that can be ordered either in ascending or descending 

order, but the exact differences between them cannot be accurately determined.  

   - Example: Grading students in exams (Excellent, Very Good, Good, Average, 

Pass, Fail). The order is clear, but the precise differences between the categories 

are not well-defined. 

- Nominal: Used to measure nominal variables, which are variables with several 

categories without any preference for one over the other. These categories cannot 

be ordered in ascending or descending order. 

   - Example: Classifying a society into males and females. For instance, assigning 

the number 1 to males and 2 to females doesn't imply any inherent superiority. 

These numbers do not hold a true meaning for the variable, and arithmetic 

operations cannot be performed on this type of variable. Nominal variables can be 

either numerical or symbolic; for example, the variable "Province" (Baghdad, 

Mosul, Basra) where we use "nominal" due to the lack of a specific order among 

the provinces. 

Enter the data into the SPSS program.  

Let's assume we have the following data and want to input it into the SPSS 

program. 

 

لكلي الدخل ا  الاستهلاك الكلي   

211  251 

275  311 

125  151 

51  111 

151  225 

111  175 

311  351 

111  151 

111  125 

251  275 
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Steps: 

1- In the main window of the program, click with the mouse once on Variable 

View as shown below 

  

  

     2- The following window will appear   
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3- In the window above, all specific settings and variables will be adjusted as 

follows: 

❖ For the first variable: 

1. In the first cell of the Name column, i.e., in the first row, write the name of 

the first variable consisting of a single word, provided that the number of 

characters does not exceed eight characters and does not include spaces, 

commas, or symbols. Therefore, we will write the name of the first variable 

 .(الدخل)

2. In the first cell of the Label column, write the full name of the first variable 

with the possibility of including spaces and symbols. So, we will write the 

name of the first variable (الدخل الكلي). 

❖ For the second variable, enter the information of this variable in the 

second row in the same open window in front of you: 

1. In the second cell of the Name column, i.e., in the second row, write the 

name of the second variable, also consisting of a single word, provided 

that the number of characters does not exceed eight characters and does 

not include spaces, commas, or symbols. Therefore, we will write the name 

of the second variable (الاستهلاك). 

2. In the second cell of the Label column, the name of the second variable is 

written in full, with the possibility of including spaces and symbols. So, we 

will write the name of the second variable (الاستهلاك الكلي). As for the other 

settings within the same window (Type, Width...), the SPSS program will 

suggest them automatically, as illustrated in the figure below. 
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We notice that the abbreviated name of the variable is the one that appears in 

front of you as the title for the column representing this variable. The full variable 

name appears when we place the mouse pointer over the abbreviated name 

without pressing.  

  

4. Then, we click on 'Data View' to return to the data input window, as shown below. 
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5. We enter the data for each variable as shown below: 

 

 

 Save File 

The file is saved in three ways: 

• The save icon located in the standard toolbar: 

 

• From the File menu, we select the Save command. 
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• Using the keyboard shortcut (Ctrl + S), in any of the three methods, the window 

shown below appears: 

We will find that the name of the file in which it was saved appears in the address 

bar as shown below 

 

 Adding a New Column 

If we want to add a new column to the previous table, meaning adding a new 

variable, because as mentioned earlier, columns represent variables in an SPSS 

program table. For example, if we want to add a column titled "Savings" before the 

consumption column, we follow these steps: 

1. Place the mouse cursor on the first cell of the consumption column. 

  

   نختار   مكان   الحفظ

   للملف   اسم نختار  

   Save نضغط  
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2. Open the Edit menu and choose the Insert Variable command, or select the 

command from the standard toolbar by clicking it once. 

 

We notice the addition of a new variable (new column) in the specified location 

with a default name. 

❖ (VAR00003) is automatically determined by the program as illustrated 

below. 

4. We modify the default name from (VAR00003) to the nickname by going to the 

Variable View window and entering the new nickname in the Name field. 

5. Finally, we click on the Data View window to return to the data page and 

observe the change in the column name as shown below. 
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 Delete Column 

If we want to delete the column that was added to the previous table under the title 

'Savings,' we follow the following steps: 

Highlight the 'Savings' column by clicking on the column name (Savings) once. A 

single click will select the entire column, as shown below 
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We choose the "Delete" command from the keyboard or right-click twice on the 

selected column. A window appears, and we select the "Clear" command to delete 

the column. 

 To add a new row: 

If we want to add a new row to the previous table, adding a new case, as explained 

earlier, where the rows represent cases in an SPSS program table. For example, if 

we want to add a new row before the eighth row, we follow these steps: 

1. Place the mouse pointer on the first cell of the eighth row. 

2. Open the "Edit" menu and choose the "Insert Cases" command, or choose the 

command from the standard toolbar by clicking on it once. 

 

3-We notice that a new row has been added in the required location, as shown 

below 
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 Delete Row 

If we want to delete a row, for example, delete the new row that has been added to 

the previous table, we follow these steps: 

1. Highlight the new row by clicking on the row number (8) once. The entire row 

will be selected as shown below 

 

2. Choose the Delete command from the keyboard or right-click twice on the 

selected row. A window will appear, and you select the Clear command to delete 

the row. 

o Controlling the Size and Style of Writing in the Data Page 

To change the size and style of the font on the data page, follow these steps: 

1. Open the View menu and choose the Fonts command. A window will appear as 

illustrated below: 
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We change the font type from the (FONT) box, the font style from the (Font Style) 

box, and the font size from the (SIZE) box, and then click OK 

 

 Form of the Questionnaire 

The questionnaire consists of a set of diverse questions that are interconnected in 

a way that achieves the researcher's goal through the problem posed in their 

research. The researcher sends the questionnaire by mail or by any other means 

to a group of individuals or institutions selected for the study, so that they can fill 

it out and then return it to the researcher. The number of questions included in the 

questionnaire should be sufficient and satisfactory to achieve the research goal, 

regardless of their quantity. Below is a model for a questionnaire form. 

  

.                               
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Data encoding is the process of converting the responses to each question in the 

questionnaire into numbers to facilitate input into the SPSS program. 

Consequently, statistical analysis can be performed on this data to obtain results. 

According to the SPSS program, each question in the questionnaire will be treated 

as a variable, representing the columns. The individuals answering the 

questionnaire questions will be considered cases, representing the rows (each 

questionnaire form specific to a particular individual will constitute one row, and 

so on). 

 Data encoding in the questionnaire is done according to the following 

steps: 

1. The questionnaire forms are numbered after being answered by the relevant 

individuals. For example, if there are ten questionnaire forms, the first form is 

given the number (1), the second form is given the number (2), and so on, up to 

the tenth form, which is given the number (10). Thus, there will be ten rows (ten 

observations under each variable). 

2. Questions with binary responses (questions with only two possible answers, 

such as yes or no) are encoded by assigning an integer. For example, (1) can 

represent "yes," and (2) can represent "no" or indicate the gender of the person 

as male or female. 

3. Questions related to individuals' opinions on a specific topic are assigned a 

number for each case, as illustrated in the table: 

 حالات المتغير  اوافق بشدة  اوافق محايد ارفض  ارفض بشدة 

 الرقم  5 4 3 2 1

 

 The steps to enter data are as follows: 

1. Open a new file in the SPSS program. 

2. In the data page, click on "Variable View." A window with variable properties 

will appear. In the "Name" field, enter the variable name. Then, open the "Values" 

field, and a window will appear as shown below. 
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We write in the 'Value' field the first number, for example, (5). Then, in the 'Label' 

field, we write the corresponding status for this number, which is (strongly agree). 

After that, we press 'Add,' and we repeat the process for the remaining numbers 

as illustrated below. 

 

 

3. Press OK to return to the Variable Properties window. 

4. Move to the Decimals box and set the number of decimal places to zero. 

5. Move to the Width box and set the number of integer digits to only one. 

6. Return to the Data window by clicking on Data View and enter the data for each 

form. 

 


